openSUSE Security Update : libpng16 (openSUSE-SU-2015:0161-1)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

libpng was updated to fix some security issues :

- CVE-2014-9495 [bnc#912076]: Heap-buffer overflow
png_combine_row() with very wide interlaced images

- CVE-2015-0973 [bnc#912929]: overflow in
png_read_IDAT_data

libpng is now also build with -DPNG_SAFE_LIMITS_SUPPORTED.

See also :

http://lists.opensuse.org/opensuse-updates/2015-01/msg00084.html
https://bugzilla.opensuse.org/show_bug.cgi?id=912076
https://bugzilla.opensuse.org/show_bug.cgi?id=912929

Solution :

Update the affected libpng16 packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 81063 ()

Bugtraq ID:

CVE ID: CVE-2014-9495
CVE-2015-0973

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now