Flash Player <= 16.0.0.287 Unspecified Code Execution (APSA15-01 / APSB15-03)

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a browser plugin that is affected by
multiple code execution vulnerabilities.

Description :

According to its version, the Adobe Flash Player installed on the
remote Windows host is equal or prior to 16.0.0.287. It is, therefore,
affected by the following vulnerabilities :

- A use-after-free error exists that allows an attacker to
crash the application or execute arbitrary code.
(CVE-2015-0311)

- A double-free error exists that allows an attacker to
crash the application or possibly execute arbitrary
code. (CVE-2015-0312)

See also :

https://helpx.adobe.com/security/products/flash-player/apsa15-01.html
https://helpx.adobe.com/security/products/flash-player/apsb15-03.html
http://www.nessus.org/u?0cb17c10
https://www.adobe.com/products/flashplayer/distribution3.html

Solution :

Upgrade to Adobe Flash Player version 16.0.0.296 or later.

Alternatively, Adobe has made version 13.0.0.264 available for those
installations that cannot be upgraded to 16.x.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:H/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 80998 ()

Bugtraq ID: 72283
72343

CVE ID: CVE-2015-0311
CVE-2015-0312

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now