IBM WebSphere Service Registry and Repository 8.0 < 8.0.0.3 Multiple Vulnerabilities

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has a web application installed that is affected by
multiple vulnerabilities.

Description :

The version of IBM WebSphere Service Registry and Repository (WSRR) is
version 8.0 prior to 8.0.0.3. It is therefore, affected by multiple
vulnerabilities :

- An unspecified DOM based cross-site scripting (XSS)
vulnerability in the WSRR web UI. (CVE-2014-6132)

- WSSR web interface issues a cookie that is not declared
SSL only. (CVE-2014-6153)

- An unspecified path traversal vulnerability in the
SERVICEREGISTRY UI. (CVE-2014-6155)

- An unspecified script injection vulnerability in WSSR
widgets. (CVE-2014-6178)

- An unspecified DOM based cross-site scripting (XSS)
vulnerability in the WSRR web UI. (CVE-2014-6179)

- Improper enforcement of object access control
restrictions. (CVE-2014-6186)

- An unspecified cross-site request forgery (XSRF)
vulnerability. (CVE-2014-6187)

- Unspecified cross-site scripting (XSS) vulnerabilities.
(CVE-2014-6188)

See also :

http://www-01.ibm.com/support/docview.wss?uid=swg21693387

Solution :

Upgrade to IBM WebSphere Service Registry and Repository Fix Pack
8.0.0.3.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now