openSUSE Security Update : MozillaThunderbird (openSUSE-SU-2014:1654-1)

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This MozillaThunderbird update fixes several security and non security
issues :

Changes in MozillaThunderbird :

- update to Thunderbird 31.3.0 (bnc#908009)

- MFSA 2014-83/CVE-2014-1587 Miscellaneous memory safety
hazards

- MFSA 2014-85/CVE-2014-1590 (bmo#1087633) XMLHttpRequest
crashes with some input streams

- MFSA 2014-87/CVE-2014-1592 (bmo#1088635) Use-after-free
during HTML5 parsing

- MFSA 2014-88/CVE-2014-1593 (bmo#1085175) Buffer overflow
while parsing media content

- MFSA 2014-89/CVE-2014-1594 (bmo#1074280) Bad casting
from the BasicThebesLayer to BasicContainerLayer

- fix bashism in mozilla.sh script

- Limit RAM usage during link for ARM

- remove add-plugins.sh and use /usr/share/myspell
directly (bnc#900639)

See also :

http://lists.opensuse.org/opensuse-updates/2014-12/msg00067.html
https://bugzilla.opensuse.org/show_bug.cgi?id=900639
https://bugzilla.opensuse.org/show_bug.cgi?id=908009

Solution :

Update the affected MozillaThunderbird packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 80095 ()

Bugtraq ID:

CVE ID: CVE-2014-1587
CVE-2014-1590
CVE-2014-1592
CVE-2014-1593
CVE-2014-1594

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now