Mac OS X : Apple Safari < 6.2.2 / 7.1.2 / 8.0.2 Multiple Vulnerabilities

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.


Synopsis :

The remote host contains a web browser that is affected by multiple
vulnerabilities.

Description :

The version of Apple Safari installed on the remote Mac OS X host is a
version prior to 6.2.2 / 7.1.2 / 8.0.2. It is, therefore, affected by
the following vulnerabilities in WebKit :

- An SVG loaded in an IMG element could load a CSS file
cross-origin. This can allow data exfiltration.
(CVE-2014-4465)

- A UI spoofing flaw exists in the handling of scrollbar
boundaries. Visiting websites that frame malicious
content can allow the UI to be spoofed. (CVE-2014-1748)

- Multiple memory corruption issues exist that can lead to
an unexpected application crash or potential arbitrary
code execution by means of malicious website content.
(CVE-2014-4452, CVE-2014-4459, CVE-2014-4466,
CVE-2014-4468, CVE-2014-4469, CVE-2014-4470,
CVE-2014-4471, CVE-2014-4472, CVE-2014-4473,
CVE-2014-4474, CVE-2014-4475)

Note that the 6.2.2 / 7.1.2 / 8.0.2 Safari updates include the
security content of the 6.2.1 / 7.1.1 / 8.0.1 updates. These more
recent updates, however, were released to fix potential issues with
the installation of the previous patch release.

See also :

http://support.apple.com/en-us/HT1222
http://www.securityfocus.com/archive/1/534148
http://support.apple.com/en-us/HT6597

Solution :

Upgrade to Apple Safari 6.2.2 / 7.1.2 / 8.0.2 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now