VMware Security Updates for vCenter Server (VMSA-2014-0012)

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.


Synopsis :

The remote host has a virtualization management application installed
that is affected by multiple security vulnerabilities.

Description :

The VMware vCenter Server installed on the remote host is version 5.0
prior to Update 3c, 5.1 prior to Update 3, or 5.5 prior to Update 2.
It is, therefore, affected by multiple vulnerabilities in third party
libraries :

- Due to improper certificate validation when connecting
to a CIM server on an ESXi host, an attacker can
perform man-in-the-middle attacks. (CVE-2014-8371)

- The bundled version of Oracle JRE is prior to 1.6.0_81
and thus is affected by multiple vulnerabilities. Note
that this only affects version 5.1 and 5.0 of vCenter
but is only fixed in 5.1 Update 3.

See also :

http://www.vmware.com/security/advisories/VMSA-2014-0012.html
http://lists.vmware.com/pipermail/security-announce/2014/000283.html

Solution :

Upgrade to VMware vCenter Server 5.5u2 (5.5.0 build-2001466) / 5.1u3
(5.1.0 build-2306353) / 5.0u3c (5.0.0 build-2210222) or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false