VMware vCenter Operations Management Suite Multiple Vulnerabilities (VMSA-2014-0007)

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has a virtualization appliance installed that is
affected by multiple vulnerabilities.

Description :

The version of vCenter Operations Manager installed on the remote host
is prior to 5.8.2. It is, therefore, affected by the following
vulnerabilities :

- An error exists in the included Apache Tomcat version
related to handling 'Content-Type' HTTP headers and
multipart requests such as file uploads that could
allow denial of service attacks. (CVE-2014-0050)

- A security bypass error exists due to the included
Apache Struts2 component, allowing manipulation of the
ClassLoader via the 'class' parameter, which is directly
mapped to the getClass() method. A remote,
unauthenticated attacker can take advantage of this
issue to manipulate the ClassLoader used by the
application server, allowing for the bypass of certain
security restrictions. Note that CVE-2014-0112 exists
because CVE-2014-0094 was not a complete fix.
(CVE-2014-0094, CVE-2014-0112)

See also :

http://lists.vmware.com/pipermail/security-announce/2014/000257.html
http://www.nessus.org/u?4d46f364
http://www.nessus.org/u?1fe3ac72
http://www.nessus.org/u?be20e92d

Solution :

Upgrade to vCenter Operations Manager 5.7.3 / 5.8.2 or later.

Alternatively, the vendor has provided a workaround for the security
bypass error.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 76388 ()

Bugtraq ID: 65400
65999
67064

CVE ID: CVE-2014-0050
CVE-2014-0094
CVE-2014-0112

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now