openSUSE Security Update : libopenssl-devel (openSUSE-SU-2012:0083-1)

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

Various security vulnerabilities have been fixed in openssl :

- DTLS plaintext recovery attack (CVE-2011-4108)

- uninitialized SSL 3.0 padding (CVE-2011-4576)

- malformed RFC 3779 data can cause assertion failures
(CVE-2011-4577)

- SGC restart DoS attack (CVE-2011-4619)

- invalid GOST parameters DoS attack (CVE-2012-0027)

See also :

http://lists.opensuse.org/opensuse-updates/2012-01/msg00029.html
https://bugzilla.novell.com/show_bug.cgi?id=739719

Solution :

Update the affected libopenssl-devel packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: SuSE Local Security Checks

Nessus Plugin ID: 75908 ()

Bugtraq ID:

CVE ID: CVE-2011-4108
CVE-2011-4576
CVE-2011-4577
CVE-2011-4619
CVE-2012-0027

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now