openSUSE Security Update : libgnomesu (openSUSE-SU-2011:0694-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

The libgnomesu pam backend did not check the return value of the
setuid() functions. Local users could exploit that to gain root
privileges (CVE-2011-1946).

See also :

http://lists.opensuse.org/opensuse-updates/2011-06/msg00041.html
https://bugzilla.novell.com/show_bug.cgi?id=695627

Solution :

Update the affected libgnomesu packages.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 75580 ()

Bugtraq ID:

CVE ID: CVE-2011-1946

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now