openSUSE Security Update : php5 (openSUSE-SU-2014:0784-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

php5 was updated to fix several security issues.

These issues were fixed :

- Performance degradation by too many file_printf calls
(CVE-2014-0237)

- DoS in Fileinfo component (CVE-2014-0238)

- NULL pointer dereference in GD XPM decoder
(CVE-2014-2497)

- Privilege escalation due to insecure default config
(CVE-2014-0185)

See also :

http://lists.opensuse.org/opensuse-updates/2014-06/msg00024.html
https://bugzilla.novell.com/show_bug.cgi?id=868624
https://bugzilla.novell.com/show_bug.cgi?id=875826
https://bugzilla.novell.com/show_bug.cgi?id=880904
https://bugzilla.novell.com/show_bug.cgi?id=880905

Solution :

Update the affected php5 packages.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: SuSE Local Security Checks

Nessus Plugin ID: 75385 ()

Bugtraq ID: 67118
67759
67765

CVE ID: CVE-2014-0185
CVE-2014-0237
CVE-2014-0238
CVE-2014-2497

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now