openSUSE Security Update : libvirt (openSUSE-SU-2014:0674-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update fixes the following issues with libvirt :

- bnc#875694: Fix migration with QEMU 1.6. QEMU 1.6.0
introduced new migration status: setup. Libvirt does not
expect such string in QMP and refuses to migrate with
error 'unexpected migration status in setup'

- Patch to prevent expansion of entities when parsing XML
files. This vulnerability allowed malicious users to
read arbitrary files or cause a denial of service
(CVE-2014-0179).

See also :

http://lists.opensuse.org/opensuse-updates/2014-05/msg00052.html
https://bugzilla.novell.com/show_bug.cgi?id=873705
https://bugzilla.novell.com/show_bug.cgi?id=875694

Solution :

Update the affected libvirt packages.

Risk factor :

Low / CVSS Base Score : 1.9
(CVSS2#AV:L/AC:M/Au:N/C:N/I:N/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 75362 ()

Bugtraq ID:

CVE ID: CVE-2014-0179

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now