openSUSE Security Update : xorg-x11-server (openSUSE-SU-2013:0937-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

-
U_xf86-fix-flush-input-to-work-with-Linux-evdev-device.p
atch

- So when we VT switch back and attempt to flush the input
devices, we don't succeed because evdev won't return
part of an event, since we were only asking for 4 bytes,
we'd only get -EINVAL back. This could later cause
events to be flushed that we shouldn't have gotten. This
is a fix for CVE-2013-1940. (bnc#814653)

See also :

http://lists.opensuse.org/opensuse-updates/2013-05/msg00016.html
http://lists.opensuse.org/opensuse-updates/2013-06/msg00073.html
https://bugzilla.novell.com/show_bug.cgi?id=814653

Solution :

Update the affected xorg-x11-server packages.

Risk factor :

Low / CVSS Base Score : 2.1
(CVSS2#AV:L/AC:L/Au:N/C:P/I:N/A:N)

Family: SuSE Local Security Checks

Nessus Plugin ID: 74992 ()

Bugtraq ID:

CVE ID: CVE-2013-1940

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now