OpenSSH < 6.6 Multiple Vulnerabilities

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.

Synopsis :

The SSH server on the remote host is affected by multiple

Description :

According to its banner, the version of OpenSSH running on the remote
host is prior to 6.6. It is, therefore, affected by the following
vulnerabilities :

- A flaw exists due to a failure to initialize certain
data structures when is modified to enable
the J-PAKE protocol. An unauthenticated, remote attacker
can exploit this to corrupt memory, resulting in a
denial of service condition and potentially the
execution of arbitrary code. (CVE-2014-1692)

- An error exists related to the 'AcceptEnv' configuration
setting in sshd_config due to improper processing of
wildcard characters. An unauthenticated, remote attacker
can exploit this, via a specially crafted request, to
bypass intended environment restrictions.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

Solution :

Upgrade to OpenSSH version 6.6 or later.

Risk factor :

High / CVSS Base Score : 7.5
CVSS Temporal Score : 6.5
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 73079 ()

Bugtraq ID: 65230

CVE ID: CVE-2014-1692

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now