Wireshark 1.8.x < 1.8.13 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.

Synopsis :

The remote Windows host contains an application that is affected by
multiple vulnerabilities.

Description :

The installed version of Wireshark 1.8.x is a version prior to 1.8.13.
It is, therefore, affected by denial of service vulnerabilities in the
following dissectors :

- NFS dissector (CVE-2014-2281)
- RLC dissector (CVE-2014-2283)

Additionally, a flaw exists in the 'mpeg_read()' function in the MPEG
file parser, 'wiretap/mpeg.c', where input is not properly sanitized
when handling oversized records. A context-dependent attacker could
cause a buffer overflow with a specially crafted packet trace file,
resulting in a denial of service or potentially arbitrary code
execution. (CVE-2014-2299)

See also :


Solution :

Upgrade to Wireshark version 1.8.13 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 8.1
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 72941 ()

Bugtraq ID: 66066

CVE ID: CVE-2014-2281

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now