PuTTY 0.52 to 0.62 Multiple Vulnerabilities

This script is Copyright (C) 2013-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has an SSH client that is affected by multiple
vulnerabilities.

Description :

The remote host has an installation of PuTTY version 0.52 or greater
but earlier than version 0.63. As such, it is reportedly affected by
the following vulnerabilities :

- An overflow error exists in the function 'modmul' in
the file 'putty/sshbn.c' that could allow heap
corruption when handling DSA signatures. (CVE-2013-4206)

- A buffer overflow error exists related to modular
inverse calculation, non-coprime values and DSA
signature verification. (CVE-2013-4207)

- An error exists in the file 'putty/sshdss.c' that could
allow disclosure of private key material.
(CVE-2013-4208)

- Multiple overflow errors exist in the files 'sshrsa.c'
and 'sshdss.c'. (CVE-2013-4852)

See also :

http://www.nessus.org/u?4834e145
http://www.nessus.org/u?20c27652
http://www.nessus.org/u?7bdd07a8
http://www.nessus.org/u?e1b0243c
http://www.search-lab.hu/advisories/secadv-20130722

Solution :

Upgrade to PuTTY version 0.63 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.2
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 69318 ()

Bugtraq ID: 61599
61644
61645
61649

CVE ID: CVE-2013-4206
CVE-2013-4207
CVE-2013-4208
CVE-2013-4852

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now