This script is Copyright (C) 2013-2016 Tenable Network Security, Inc.
The remote Windows host has an SSH client that is affected by multiple
The remote host has an installation of PuTTY version 0.52 or greater
but earlier than version 0.63. As such, it is reportedly affected by
the following vulnerabilities :
- An overflow error exists in the function 'modmul' in
the file 'putty/sshbn.c' that could allow heap
corruption when handling DSA signatures. (CVE-2013-4206)
- A buffer overflow error exists related to modular
inverse calculation, non-coprime values and DSA
signature verification. (CVE-2013-4207)
- An error exists in the file 'putty/sshdss.c' that could
allow disclosure of private key material.
- Multiple overflow errors exist in the files 'sshrsa.c'
and 'sshdss.c'. (CVE-2013-4852)
See also :
Upgrade to PuTTY version 0.63 or later.
Risk factor :
Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.2
Public Exploit Available : false