FreeBSD : puppet27 and puppet -- multiple vulnerabilities (cda566a0-2df0-4eb0-b70e-ed7a6fb0ab3c)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

Moses Mendoza reports :

A vulnerability found in Puppet could allow an authenticated client to
cause the master to execute arbitrary code while responding to a
catalog request. Specifically, in order to exploit the vulnerability,
the puppet master must be made to invoke the 'template' or
'inline_template' functions during catalog compilation.

A vulnerability found in Puppet could allow an authenticated client to
connect to a puppet master and perform unauthorized actions.
Specifically, given a valid certificate and private key, an agent
could retrieve catalogs from the master that it is not authorized to
access or it could poison the puppet master's caches for any
puppet-generated data that supports caching such as catalogs, nodes,
facts, and resources. The extent and severity of this vulnerability
varies depending on the specific configuration of the master: for
example, whether it is using storeconfigs or not, which version,
whether it has access to the cache or not, etc.

A vulnerability has been found in Puppet which could allow
authenticated clients to execute arbitrary code on agents that have
been configured to accept kick connections. This vulnerability is not
present in the default configuration of puppet agents, but if they
have been configured to listen for incoming connections
('listen=true'), and the agent's auth.conf has been configured to
allow access to the `run` REST endpoint, then a client could construct
an HTTP request which could execute arbitrary code. The severity of
this issue is exacerbated by the fact that puppet agents typically run
as root.

A vulnerability has been found in Puppet that could allow a client
negotiating a connection to a master to downgrade the master's SSL
protocol to SSLv2. This protocol has been found to contain design
weaknesses. This issue only affects systems running older versions
(pre 1.0.0) of openSSL. Newer versions explicitly disable SSLv2.

A vulnerability found in Puppet could allow unauthenticated clients to
send requests to the puppet master which would cause it to load code
unsafely. While there are no reported exploits, this vulnerability
could cause issues like those described in Rails CVE-2013-0156. This
vulnerability only affects puppet masters running Ruby 1.9.3 and
higher.

This vulnerability affects puppet masters 0.25.0 and above. By
default, auth.conf allows any authenticated node to submit a report
for any other node. This can cause issues with compliance. The
defaults in auth.conf have been changed.

See also :

https://puppetlabs.com/security/cve/cve-2013-1640/
https://puppetlabs.com/security/cve/cve-2013-1652/
https://puppetlabs.com/security/cve/cve-2013-1653/
https://puppetlabs.com/security/cve/cve-2013-1654/
https://puppetlabs.com/security/cve/cve-2013-1655/
https://puppetlabs.com/security/cve/cve-2013-2275/
http://www.nessus.org/u?36c89c29
http://www.nessus.org/u?5569885b
http://www.nessus.org/u?99733077

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 9.0
(CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 65542 ()

Bugtraq ID:

CVE ID: CVE-2013-1640
CVE-2013-1652
CVE-2013-1653
CVE-2013-1654
CVE-2013-1655
CVE-2013-2275

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now