Wireshark 1.8.x < 1.8.6 Multiple Vulnerabilities

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple vulnerabilities.

Description :

The installed version of Wireshark 1.8 is earlier than 1.8.6. It is,
therefore, affected by the following vulnerabilities :

- Errors exist in the CSN.1, CIMD, DTLS, Mount, MS-MMS,
RTPS, RTPS2, and TCP dissectors that could allow them
to crash. (Bugs 8274, 8332, 8335, 8346, 8380, 8382)

- Errors exist in the AMPQ, FCSP, HART/IP, MPLS Echo,
and RELOAD dissectors that could lead to an infinite
loop, resulting in a denial of service. (Bugs 8039,
8337, 8359, 8360, 8364)

- The ACN dissector can attempt a divide by zero
operation that could lead to an application crash.
(Bug 8340)

See also :

http://www.wireshark.org/security/wnpa-sec-2013-10.html
http://www.wireshark.org/security/wnpa-sec-2013-11.html
http://www.wireshark.org/security/wnpa-sec-2013-12.html
http://www.wireshark.org/security/wnpa-sec-2013-13.html
http://www.wireshark.org/security/wnpa-sec-2013-14.html
http://www.wireshark.org/security/wnpa-sec-2013-15.html
http://www.wireshark.org/security/wnpa-sec-2013-16.html
http://www.wireshark.org/security/wnpa-sec-2013-17.html
http://www.wireshark.org/security/wnpa-sec-2013-18.html
http://www.wireshark.org/security/wnpa-sec-2013-19.html
http://www.wireshark.org/security/wnpa-sec-2013-20.html
http://www.wireshark.org/security/wnpa-sec-2013-21.html
http://www.wireshark.org/security/wnpa-sec-2013-22.html
http://www.wireshark.org/docs/relnotes/wireshark-1.8.6.html

Solution :

Upgrade to Wireshark version 1.8.6 or later.

Risk factor :

High / CVSS Base Score : 7.8
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)
CVSS Temporal Score : 6.4
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true