AIX 5.3 TL 9 : libtt (IZ52846)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote AIX host is missing a security patch.

Description :

There is a buffer overflow vulnerability in the ToolTalk library
libtt.a. A remote attacker can exploit this vulnerability when the
rpc.ttdbserver is enabled in /etc/inetd.conf.

The successful exploitation of this vulnerability allows a remote
attacker to execute arbitrary code as the root user.

The following libraries and executables are vulnerable :

/usr/dt/lib/libtt.a /usr/dt/bin/rpc.ttdbserver.

See also :

http://aix.software.ibm.com/aix/efixes/security/libtt_advisory.asc

Solution :

Install the appropriate interim fix.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
Public Exploit Available : true

Family: AIX Local Security Checks

Nessus Plugin ID: 64336 ()

Bugtraq ID:

CVE ID: CVE-2009-2727

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now