Flash Player <= 10.3.183.43 / 11.5.502.110 Multiple Vulnerabilities (APSB12-27)

This script is Copyright (C) 2012-2015 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the instance of Flash Player installed on the
remote Windows host is 11.x equal to or earlier than 11.5.502.110, or
10.x equal to or earlier than 10.3.183.43. It is, therefore,
potentially affected by multiple vulnerabilities :

- An unspecified error exists that can allow a buffer
overflow and arbitrary code execution. (CVE-2012-5676)

- An unspecified error exists that can allow an integer
overflow and arbitrary code execution. (CVE-2012-5677)

- An unspecified error exists that can lead to memory
corruption and arbitrary code execution. (CVE-2012-5678)

See also :

http://www.zerodayinitiative.com/advisories/ZDI-13-021/
http://www.adobe.com/support/security/bulletins/apsb12-27.html

Solution :

Upgrade to Adobe Flash Player version 10.3.183.48 / 11.5.502.135 or
later, or Google Chrome PepperFlash 11.5.31.5 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 63242 ()

Bugtraq ID: 56892
56896
56898

CVE ID: CVE-2012-5676
CVE-2012-5677
CVE-2012-5678

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now