VMware Player 4.x < 4.0.5 Multiple Vulnerabilities (VMSA-2012-0015)

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote host has a virtualization application that is affected by
multiple vulnerabilities.

Description :

The VMware Player 4.x install detected on the remote host is earlier
than 4.0.5 and is, therefore, potentially affected by the following
vulnerabilities :

- Certain processes, when created, have weak security
permissions assigned. It is possible to commandeer
these process threads, which could result in elevation
of privileges in the context of the host. (CVE-2012-5458)

- A DLL binary planning vulnerability exists that could be
exploited by an attacker to execute arbitrary code on
the remote host. (CVE-2012-5459)

See also :

http://www.vmware.com/security/advisories/VMSA-2012-0015.html
http://lists.vmware.com/pipermail/security-announce/2012/000193.html

Solution :

Upgrade to VMware Player 4.0.5 or later.

Risk factor :

High / CVSS Base Score : 8.3
(CVSS2#AV:A/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.1
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 63076 ()

Bugtraq ID: 56469
56470

CVE ID: CVE-2012-5458
CVE-2012-5459

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now