Google Chrome < 23.0.1271.64 Multiple Vulnerabilities

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.

Synopsis :

The remote host contains a web browser that is affected by multiple

Description :

The version of Google Chrome installed on the remote host is earlier
than 23.0.1271.64 and is, therefore, affected by the following
vulnerabilities :

- Use-after-free errors exist related to SVG filter
handling, video layout, extension tab handling and
plug-in placeholder handling. (CVE-2012-5116,
CVE-2012-5121, CVE-2012-5125, CVE-2012-5126)

- An error exists related to inappropriate SVG
subresource loading in the 'img' context.

- A race condition exists related to 'Pepper' buffer
handling. (CVE-2012-5119)

- A bad cast error exists related to input handling.

- Out-of-bounds reads exist related to Skia.

- A memory corruption error exists related to texture
handling. (CVE-2012-5124)

- An integer overflow error exists related to 'WebP'
handling. This error can lead to out-of-bounds reads.

- An improper write error exists related to the 'v8'
JavaScript engine. (CVE-2012-5128)

Successful exploitation of any of these issues could lead to an
application crash or even allow arbitrary code execution, subject to the
user's privileges.

See also :

Solution :

Upgrade to Google Chrome 23.0.1271.64 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
CVSS Temporal Score : 5.9
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now