Flash Player <= 10.3.183.22 / 11.4.402.264 Multiple Vulnerabilities (APSB12-19)

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the instance of Flash Player installed on the
remote Windows host is 11.x equal to or earlier than 11.4.402.264, or
10.x equal to or earlier than 10.3.183.22. It is, therefore,
potentially affected by multiple vulnerabilities :

- Multiple memory corruption vulnerabilities could lead to
code execution. (CVE-2012-4163, CVE-2012-4164,
CVE-2012-4165)

- An integer overflow vulnerability exists that could
lead to code execution. (CVE-2012-4167)

- A cross-domain information leak vulnerability exists.
(CVE-2012-4168)

- A crash can be caused by a logic error involving
multiple dialogs in Firefox. (CVE-2012-4171)

- A Matrix3D integer overflow vulnerability could lead
to code execution. (CVE-2012-5054)

See also :

http://www.securityfocus.com/archive/1/524143/30/0/threaded
http://www.adobe.com/support/security/bulletins/apsb12-19.html

Solution :

Upgrade to Adobe Flash Player version 10.3.183.23, 11.4.402.265 or
later, or Google Chrome PepperFlash 11.3.31.230 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now