Google Chrome < 19.0.1084.46 Multiple Vulnerabilities

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

The remote host contains a web browser that is affected by multiple
vulnerabilities.

Description :

The version of Google Chrome installed on the remote host is earlier
than 19.0.1084.46 and is, therefore, affected by the following
vulnerabilities :

- Video content with FTP can cause crashes.
(CVE-2011-3083)

- Internal links are not loaded in their own process.
(CVE-2011-3084)

- Lengthy auto-filled values can corrupt the user
interface. (CVE-2011-3085)

- Use-after free errors exist related to style elements,
table handling, indexed DBs, GTK 'omnibox' handling,
and corrupt font encoding names related to PDF handling.
(CVE-2011-3086, CVE-2011-3089, CVE-2011-3091,
CVE-2011-3096, CVE-2011-3099)

- An error exists related to windows navigation.
(CVE-2011-3087)

- Out-of-bounds read errors exist related to hairline
drawing, glyph handling, Tibetan, OGG containers, PDF
sampled functions and drawing dash paths.
(CVE-2011-3088, CVE-2011-3093, CVE-2011-3094,
CVE-2011-3095, CVE-2011-3097, CVE-2011-3100)

- A race condition related to workers exists.
(CVE-2011-3090)

- An invalid write exists in the v8 regex processing.
(CVE-2011-3092)

- An error exists related to Windows Media Player plugin
and the search path. (CVE-2011-3098)

- An off-by-one out-of-bounds write error exists in
libxml. (CVE-2011-3102)

See also :

http://www.nessus.org/u?57869300
http://www.nessus.org/u?ac840e6e

Solution :

Upgrade to Google Chrome 19.0.1084.46 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now