Flash Player <= 10.3.183.14 / 11.1.102.55 Multiple Vulnerabilities (APSB12-03)

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the instance of Flash Player installed on
the remote Windows host is 10.x equal to or earlier than 10.3.183.14
or 11.x equal to or earlier than 11.1.102.55. It is, therefore,
reportedly affected by several critical vulnerabilities :

- Multiple unspecified memory corruption issues exist that
could lead to code execution. (CVE-2012-0751,
CVE-2012-0754)

- An unspecified type confusion memory corruption
vulnerability exists that could lead to code execution.
(CVE-2012-0752)

- An MP4 parsing memory corruption issue exists that
could lead to code execution. (CVE-2012-0753)

- Multiple unspecified security bypass vulnerabilities
exist that could lead to code execution. (CVE-2012-0755,
CVE-2012-0756)

- A universal cross-site scripting issue exists that could
be used to take actions on a user's behalf on any
website or webmail provider. (CVE-2012-0767)

See also :

http://www.nessus.org/u?2bd088e6
http://zerodayinitiative.com/advisories/ZDI-12-047/
http://www.zerodayinitiative.com/advisories/ZDI-12-080/
http://seclists.org/fulldisclosure/2012/Jun/67
http://www.adobe.com/support/security/bulletins/apsb12-03.html

Solution :

Upgrade to Adobe Flash version 10.3.183.15 / 11.1.102.62 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:H/RL:OF/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now