SuSE 10 Security Update : PostgreSQL (ZYPP Patch Number 7404)

This script is Copyright (C) 2011-2012 Tenable Network Security, Inc.


Synopsis :

The remote SuSE 10 host is missing a security-related patch.

Description :

A buffer overflow in the intarray module potentially allowed attackers
to execute arbitrary code as the user running postgresql.
(CVE-2010-4015:CVSS v2 Base Score: 4.9)

Additionally a possible log forging problem was fixed too.
(CVE-2010-4014)

See also :

http://support.novell.com/security/cve/CVE-2010-4014.html
http://support.novell.com/security/cve/CVE-2010-4015.html

Solution :

Apply ZYPP patch number 7404.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 57244 ()

Bugtraq ID:

CVE ID: CVE-2010-4014
CVE-2010-4015

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now