Apache Tomcat 6.x < 6.0.35 Multiple Vulnerabilities

This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 6.x listening on the remote host is prior to 6.0.35. It is,
therefore, affected by multiple vulnerabilities :

- Specially crafted requests are incorrectly processed
by Tomcat and can cause the server to allow injection
of arbitrary AJP messages. This can lead to
authentication bypass and disclosure of sensitive
information. (CVE-2011-3190)

- An information disclosure vulnerability exists. Request
information is cached in two objects and these objects
are not recycled at the same time. Further requests can
obtain sensitive information if certain error conditions
occur. (CVE-2011-3375)

- Large numbers of crafted form parameters can cause
excessive CPU consumption due to hash collisions.
(CVE-2011-4858, CVE-2012-0022)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :


Solution :

Upgrade to Apache Tomcat version 6.0.35 or later.

Risk factor :

High / CVSS Base Score : 7.5
CVSS Temporal Score : 6.5
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 57080 ()

Bugtraq ID: 49353

CVE ID: CVE-2011-3190

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now