Wireshark 1.4.x < 1.4.10 Multiple Vulnerabilities

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple vulnerabilities.

Description :

The installed version of Wireshark is 1.4.x before 1.4.10. This
version is affected by the following vulnerabilities :

- An error exists in the Infiniband dissector that can
allow a NULL pointer to be dereferenced when processing
certain malformed packets. (CVE-2011-4101)

- A buffer overflow exists in the ERF file reader and can
be triggered when processing certain malformed packets.
(CVE-2011-4102)

See also :

http://www.wireshark.org/security/wnpa-sec-2011-18.html
http://www.wireshark.org/security/wnpa-sec-2011-19.html
http://www.wireshark.org/docs/relnotes/wireshark-1.4.10.html

Solution :

Upgrade to Wireshark version 1.4.10 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 56689 ()

Bugtraq ID: 50481
50486

CVE ID: CVE-2011-4101
CVE-2011-4102

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now