Firefox 3.6 < 3.6.20 Multiple Vulnerabilities

This script is Copyright (C) 2011-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The installed version of Firefox 3.6 is earlier than 3.6.20. As
such, it is potentially affected by the following security issues :

- A dangling pointer vulnerability exists in an SVG text
manipulation routine. (CVE-2011-0084)

- A DOM accounting error exists in the 'appendChild'
JavaScript function that can allow an invalid pointer
to be dereferenced. (CVE-2011-2378)

- An error exists in 'ThinkPadSensor::Startup' that can
allow malicious DLLs to be loaded. (CVE-2011-2980)

- An error exists in the event management code that can
allow JavaScript to execute in the context of a
different website and possibly in the
chrome-privileged context. (CVE-2011-2981)

- Various unspecified memory safety issues exist.
(CVE-2011-2982)

- A cross-domain information disclosure vulnerability
exists if the configuration option 'RegExp.input' is
set. (CVE-2011-2983)

- A privilege escalation vulnerability exists if web
content is registered to handle 'drop' events and a
browser tab is dropped in that element's area. This
can allow the web content to execute with browser
chrome privileges. (CVE-2011-2984)

See also :

https://www.mozilla.org/en-US/security/advisories/mfsa2011-30/
http://www.zerodayinitiative.com/advisories/ZDI-11-270/
http://www.zerodayinitiative.com/advisories/ZDI-11-271/

Solution :

Upgrade to Firefox 3.6.20 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now