This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.
The remote web server is affected by multiple vulnerabilities.
According to its self-reported version number, the instance of Apache
Tomcat 7.x listening on the remote host is prior to 7.0.17. It is,
therefore, affected by the following vulnerabilities :
- An error handling issue exists related to the
MemoryUserDatabase that allows user passwords to be
disclosed through log files. (CVE-2011-2204)
- If loaded before other web applications, a malicious web
application can potentially access or modify the
web.xml, context.xml, and TLD files of other web
applications on the system. (CVE-2011-2481)
- An input validation error exists that allows a local
attacker to either bypass security or carry out denial
of service attacks when the APR or NIO connectors are
Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.
See also :
Upgrade to Apache Tomcat version 7.0.19 or later. Note that versions
7.0.17 and 7.0.18 are not affected but were never officially released.
Risk factor :
Medium / CVSS Base Score : 4.4
CVSS Temporal Score : 3.3
Public Exploit Available : false