Foxit Reader < 4.0.0.0619 FreeType Engine RCE

This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.


Synopsis :

A PDF viewer installed on the remote host is affected by a remote code
execution vulnerability.

Description :

The version of Foxit Reader installed on the remote Windows host is
prior to 4.0.0.0619. It is, therefore, affected by a remote code
execution vulnerability in the FreeType engine due to an integer
overflow condition in the Type 1 font decoder. An attacker can exploit
this, by tricking a user into opening a crafted PDF file, to cause a
denial of service or to execute arbitrary code with the user's
privileges.

See also :

https://technet.microsoft.com/library/security/msvr11-005
https://www.foxitsoftware.com/support/security-bulletins.php
https://www.foxitsoftware.com/company/press.php?id=191

Solution :

Upgrade to Foxit Reader version 4.0.0.0619 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 55422 ()

Bugtraq ID: 48359

CVE ID: CVE-2011-1908

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now