openSUSE Security Update : libpython2_6-1_0 (openSUSE-SU-2010:1049-1)

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

- a race condition in the accept() implementation of
smtpd.py could lead to a denial of service
(CVE-2010-3493).

- integer overflows and insufficient size checks could
crash the audioop module (CVE-2010-2089, CVE-2010-1634).

See also :

http://lists.opensuse.org/opensuse-updates/2010-12/msg00027.html
https://bugzilla.novell.com/show_bug.cgi?id=609759
https://bugzilla.novell.com/show_bug.cgi?id=609761
https://bugzilla.novell.com/show_bug.cgi?id=638233

Solution :

Update the affected libpython2_6-1_0 packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 53756 ()

Bugtraq ID:

CVE ID: CVE-2010-1634
CVE-2010-2089
CVE-2010-3493

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now