openSUSE Security Update : apache2-mod_php5 (openSUSE-SU-2010:1012-1)

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

Insufficient handling of certain character sequences in the
utf8_decode() function could be leveraged to conduct
cross-site-scripting (XSS) attacks (CVE-2010-3870). php5 could also
consume large amounts of memory and crash if a long mail address was
passed to filter_var() with parmeter FILTER_VALIDATE_EMAIL
(CVE-2010-3710).

See also :

http://lists.opensuse.org/opensuse-updates/2010-12/msg00006.html
https://bugzilla.novell.com/show_bug.cgi?id=650700

Solution :

Update the affected apache2-mod_php5 packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 53652 ()

Bugtraq ID:

CVE ID: CVE-2010-3710
CVE-2010-3870

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now