Firefox 4.0 < 4.0.1 Multiple Vulnerabilities

This script is Copyright (C) 2011-2017 Tenable Network Security, Inc.

Synopsis :

The remote Windows host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The installed version of Firefox 4.0 is earlier than 4.0.1. As such,
it is potentially affected by the following security issues :

- A buffer overflow exists in the WebGLES library.
Additionally, the Windows version was not compiled
with ASLR enabled. (CVE-2011-0068)

- Multiple memory safety issues can lead to application
crashes and possibly remote code execution.
(CVE-2011-0069, CVE-2011-0070, CVE-2011-0079,

- An information disclosure vulnerability exists in the
'xsltGenerateIdFunction' function in the included
libxslt library. (CVE-2011-1202)

See also :

Solution :

Upgrade to Firefox 4.0.1 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 7.3
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now