VMSA-2010-0012 : VMware vCenter Update Manager Fix for Jetty Web Server

This script is copyright (C) 2011-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has an update manager installed that is affected by
multiple vulnerabilities.

Description :

The version of VMware vCenter Update Manager installed on the remote
Windows host is 4.0 earlier than Update 3 or 4.1 earlier than Update 1.
The installed version is, therefore, potentially affected by multiple
vulnerabilities in the embedded Jetty Web server :

- A directory traversal vulnerability allows a remote,
unauthenticated attacker to obtain files from the
remote host. (CVE-2009-1523)

- A cross-site scripting vulnerability allows a remote
attacker to execute arbitrary script code in the user's
browser. (CVE-2009-1524)

See also :

http://lists.vmware.com/pipermail/security-announce/2011/000122.html

Solution :

Upgrade to vCenter Update Manager 4.0 Update 3 / 4.1 Update 1 or
later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 52014 ()

Bugtraq ID: 34800

CVE ID: CVE-2009-1523
CVE-2009-1524

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now