Apache Tomcat 6.x < 6.0.30 / 7.x < 7.0.5 Multiple XSS

This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by multiple cross-site scripting

Description :

According to its self-reported version number, the instance of Apache
Tomcat listening on the remote host is 6.x prior to 6.0.30 or 7.x
prior to 7.0.5. It is, therefore, affected by multiple cross-site
scripting vulnerabilities in the Tomcat Manager application's
'sessionList.jsp' file. The 'sort' and 'orderby' parameters are not
properly sanitized before being returned to the user and can be used
to inject arbitrary script into the user's browser.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

Also note, in the case of Tomcat 7.x, successful exploitation requires
that the cross-site request forgery (CSRF) filter is disabled.

See also :


Solution :

Update Apache Tomcat to version 6.0.30 / 7.0.5 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.4
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 51526 ()

Bugtraq ID: 45015

CVE ID: CVE-2010-4172

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now