Wireshark < 1.2.14 / 1.4.3 Multiple Vulnerabilities

This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple vulnerabilities.

Description :

The installed version of Wireshark is 1.2.x less than 1.2.14 or 1.4.x
less than 1.4.3. Such versions are affected by the following
vulnerabilities :

- An error exists in the MAC-LTE dissector that allows a
series of malformed packets to cause a buffer overflow.
(5530)

- An error exists in the ENTTEC dissector that allows a
series of malformed packets to cause a buffer overflow.
(5539)

- An error exists in the ASN.1 BER dissector that allows
a series of malformed packets to make Wireshark exit
prematurely. (5537)

See also :

http://www.wireshark.org/security/wnpa-sec-2011-01.html
http://www.wireshark.org/security/wnpa-sec-2011-02.html
http://www.wireshark.org/docs/relnotes/wireshark-1.2.14.html
http://www.wireshark.org/docs/relnotes/wireshark-1.4.3.html

Solution :

Upgrade to Wireshark version 1.2.14 / 1.4.3 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 51458 ()

Bugtraq ID: 45634
45775

CVE ID: CVE-2010-4538
CVE-2011-0444
CVE-2011-0445

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now