Wireshark < 1.2.13 / 1.4.2 Multiple Vulnerabilities

This script is Copyright (C) 2010-2013 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple vulnerabilities.

Description :

The installed version of Wireshark is 1.2.x less than 1.2.13 or 1.4.x
less than 1.4.2. Such versions are affected by the following
vulnerabilities:

- An error exists in the LDSS dissector that allows
a series of malformed packets to cause a buffer
overflow. (5318)

- An error exists in the ZigBee ZCL dissector that allows
a series of malformed packets to cause the dissector to
enter an infinite loop. (5303)

See also :

http://www.wireshark.org/security/wnpa-sec-2010-13.html
http://www.wireshark.org/security/wnpa-sec-2010-14.html
http://www.wireshark.org/docs/relnotes/wireshark-1.2.13.html
http://www.wireshark.org/docs/relnotes/wireshark-1.4.2.html

Solution :

Upgrade to Wireshark version 1.2.13 / 1.4.2 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.4
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 50678 ()

Bugtraq ID: 44986
44987

CVE ID: CVE-2010-4300
CVE-2010-4301

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now