openSUSE Security Update : postgresql (openSUSE-SU-2010:0903-1)

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

PostgreSQL functions implemented in Perl or TCL shared a global state
even across different user user ids. A user could therefore influence
functions of other users in an unexpected or even malicious way
(CVE-2010-3433).

See also :

http://lists.opensuse.org/opensuse-updates/2010-10/msg00034.html
https://bugzilla.novell.com/show_bug.cgi?id=643771

Solution :

Update the affected postgresql packages.

Risk factor :

Medium / CVSS Base Score : 6.0
(CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 50370 ()

Bugtraq ID:

CVE ID: CVE-2010-3433

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now