SeaMonkey < 2.0.6 Multiple Vulnerabilities

This script is Copyright (C) 2010-2017 Tenable Network Security, Inc.

Synopsis :

The remote Windows host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The installed version of SeaMonkey is earlier than 2.0.6. Such
versions are potentially affected by the following security issues :

- Multiple memory safety bugs could result in memory
corruption, potentially resulting in arbitrary code
execution. (MFSA 2010-34)

- An error in DOM attribute cloning could result in
arbitrary code execution. (MFSA 2010-35)

- An error in Mozilla's 'NodeIterator' implementation
could lead to arbitrary code execution. (MFSA 2010-36)

- An error in the code to store the names and values of
plugin parameters could lead arbitrary code execution.
(MFSA 2010-37)

- The array class used to store CSS values is affected
by an integer overflow vulnerability. (MFSA 2010-39)

- An integer overflow vulnerability exists in the
'selection' attribute of XUL <tree> element.
(MFSA 2010-40)

- A buffer overflow vulnerability in Mozilla graphics
code could lead to arbitrary code execution.
(MFSA 2010-41)

- It is possible to read and parse resources from other
domains even when the content is not valid JavaScript
leading to cross-domain data disclosure. (MFSA 2010-42)

- Multiple location bar spoofing vulnerabilities exist.
(MFSA 2010-45)

- It is possible to read data across domains by
injecting bogus CSS selectors into a target site.
(MFSA 2010-46)

- Potentially sensitive URL parameters could be leaked
across domains via script errors. (MFSA 2010-47)

See also :

Solution :

Upgrade to SeaMonkey 2.0.6 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 8.1
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now