CVE-2010-0654

MEDIUM

Description

Mozilla Firefox 3.5.x before 3.5.11 and 3.6.x before 3.6.7, Thunderbird 3.0.x before 3.0.6 and 3.1.x before 3.1.1, and SeaMonkey before 2.0.6 permit cross-origin loading of CSS stylesheets even when the stylesheet download has an incorrect MIME type and the stylesheet document is malformed, which allows remote attackers to obtain sensitive information via a crafted document.

References

http://code.google.com/p/chromium/issues/detail?id=9877

http://scarybeastsecurity.blogspot.com/2009/12/generic-cross-browser-cross-domain.html

http://websec.sv.cmu.edu/css/css.pdf

http://www.mozilla.org/security/announce/2010/mfsa2010-46.html

https://bugzilla.mozilla.org/show_bug.cgi?id=524223

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11811

Details

Source: MITRE

Published: 2010-02-18

Updated: 2017-09-19

Type: CWE-200

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM