Wireshark / Ethereal < 1.0.14 / 1.2.9 Multiple Vulnerabilities

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has an application that is affected by multiple
vulnerabilities.

Description :

The installed version of Wireshark or Ethereal is potentially
affected by multiple vulnerabilities.

- The SMB dissector can be affected by a NULL pointer
dereference. (Bug 4734)

- The ANS.1 BER dissector can be affected by a buffer
overflow.

- The SMB PIPE dissector can be affected by a NULL pointer
dereference on some platforms.

- The SigComp Universal Decompressor Virtual Machine can
be affected by an infinite loop or a buffer overflow.
(Bug 4826, 4837)

See also :

http://www.wireshark.org/security/wnpa-sec-2010-05.html
http://www.wireshark.org/security/wnpa-sec-2010-06.html

Solution :

Upgrade to Wireshark version 1.0.14 / 1.2.9 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 46864 ()

Bugtraq ID: 40728
42618

CVE ID: CVE-2010-2283
CVE-2010-2284
CVE-2010-2285
CVE-2010-2286
CVE-2010-2287

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now