Firefox 3.6 < 3.6.3 Remote Code Execution

This script is Copyright (C) 2010-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser that is affected by a
remote code execution vulnerability.

Description :

The installed version of Firefox 3.6.x is earlier than 3.6.3. Such
versions are potentially affected by a memory corruption flaw caused
by the re-use of an object that has been freed when moving DOM nodes
between documents.

A remote attacker, exploiting this flaw, can leverage this issue to
execute arbitrary code on the remote host subject to the privileges of
the user running the affected application.

See also :

https://www.mozilla.org/en-US/security/advisories/mfsa2010-25/

Solution :

Upgrade to Firefox 3.6.3 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 45403 ()

Bugtraq ID: 38952

CVE ID: CVE-2010-1121

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now