openSUSE Security Update : cups (cups-2102)

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

lppasswd when running setuid or setgid still honors environment
variables that specify the location of message files. Local attackers
could exploit that to gather information by using crafted format
strings (CVE-2010-0393).

The previous fix for a use-after-free vulnerability (CVE-2009-3553)
was incomplete (CVE-2010-0302).

See also :

https://bugzilla.novell.com/show_bug.cgi?id=574336
https://bugzilla.novell.com/show_bug.cgi?id=578215

Solution :

Update the affected cups packages.

Risk factor :

Medium / CVSS Base Score : 6.9
(CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C)
Public Exploit Available : true

Family: SuSE Local Security Checks

Nessus Plugin ID: 45102 ()

Bugtraq ID:

CVE ID: CVE-2009-3553
CVE-2010-0302
CVE-2010-0393

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now