Google Chrome < 4.0.249.89 Multiple Vulnerabilities

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.


Synopsis :

The remote host contains a web browser that is affected by multiple
vulnerabilities.

Description :

The version of Google Chrome installed on the remote host is earlier
than 4.0.249.89. Such versions are reportedly affected by multiple
vulnerabilities :

- Two errors when resolving domain names and when
interpreting configured proxy lists can be exploited to
disclose sensitive data. (Issue #12303, #22914)

- Multiple integer overflows in the V8 engine.
(Issue #31009)

- An unspecified error when processing the '<ruby>' tag.
(Issue #31692)

- Chrome leaks redirection targets via the '<iframe>'
href. (Issue #32309)

- An unspecified error when displaying domain names in
HTTP authentication dialogs. (Issue #37218)

- An integer overflow when deserializing sandbox messages.
(Issue #32915)

See also :

http://www.nessus.org/u?f0074094

Solution :

Upgrade to Google Chrome 4.0.249.89 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 44587 (google_chrome_4_0_249_89.nasl)

Bugtraq ID: 38177

CVE ID: CVE-2010-0315
CVE-2010-0556
CVE-2010-0643
CVE-2010-0644
CVE-2010-0645
CVE-2010-0646
CVE-2010-0647
CVE-2010-0649

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now