VLC Media Player < 1.0.2 Multiple Remote Buffer Overflows

This script is Copyright (C) 2009-2014 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple remote buffer overflow vulnerabilities.

Description :

The version of VLC media player installed on the remote host is
earlier than 1.0.2. Such versions are vulnerable to a stack overflow
when parsing MP4, ASF, or AVI files with an overly deep box structure.
If an attacker can trick a user into opening a specially crafted MP4,
ASF, or AVI file with the affected application, arbitrary code could
be executed subject to the user's privileges.

See also :

http://www.videolan.org/security/sa0901.html
http://www.nessus.org/u?78382b17
http://www.nessus.org/u?f4c3b223
http://www.nessus.org/u?82f87f14

Solution :

Upgrade to VLC Media Player version 1.0.2 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 41626 ()

Bugtraq ID: 36439

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now