OpenOffice < 3.1.1 Multiple Buffer Overflows

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a program affected by multiple buffer
overflows.

Description :

The version of OpenOffice installed on the remote host is earlier
than 3.1.1. Such versions are affected by several issues :

- Parsing certain records in a document table could lead
to heap-based overflows and arbitrary code execution.
(CVE-2009-0200)

- Parsing certain records in specially crafted files could
lead to heap-based overflows and arbitrary code
execution. (CVE-2009-0201)

See also :

http://secunia.com/secunia_research/2009-26
http://secunia.com/secunia_research/2009-27

Solution :

Upgrade to OpenOffice version 3.1.1 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 40826 ()

Bugtraq ID: 36200

CVE ID: CVE-2009-0200
CVE-2009-0201

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now