Google Chrome < 1.0.154.53 Multiple Vulnerabilities

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote host contains a web browser that is affected by multiple
vulnerabilities.

Description :

The version of Google Chrome installed on the remote host is earlier
than 1.0.154.53. Such versions are reportedly affected by multiple
vulnerabilities :

- The browser uses the HTTP Host header to determine the
context of a 4xx/5xx CONNECT response from a proxy
server. This could allow a man-in-the-middle attacker
to execute arbitrary script code in the context of a
legitimate server, circumventing the browser's same-
origin policy.

- The browser displays a cached certificate for 4xx/5xx
CONNECT response pages from a proxy server. A man-in-
the-middle attacker could exploit this by displaying a
spoofed web page with the valid certificate of a
legitimate website.

See also :

http://research.microsoft.com/apps/pubs/default.aspx?id=79323
http://www.nessus.org/u?f2384355

Solution :

Upgrade to Google Chrome 1.0.154.53 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:ND/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 39449 (google_chrome_1_0_154_53.nasl)

Bugtraq ID: 35380
35411

CVE ID: CVE-2009-2060
CVE-2009-2071

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now