Firefox < 3.0.8 Multiple Vulnerabilities

This script is Copyright (C) 2009-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The installed version of Firefox is earlier than 3.0.8. Such versions
are potentially affected by the following security issues :

- An XSL transformation vulnerability can be leveraged
with a specially crafted stylesheet to crash the browser
or to execute arbitrary code. (MFSA 2009-12)

- An error in the XUL tree method '_moveToEdgeShift()' can
be leveraged to trigger garbage collection routines on
objects that are still in use, leading to a browser
crash and possibly execution of arbitrary code.
(MFSA 2009-13)

See also :

https://www.mozilla.org/en-US/security/advisories/mfsa2009-12/
https://www.mozilla.org/en-US/security/advisories/mfsa2009-13/
http://www.nessus.org/u?7802b49c

Solution :

Upgrade to Firefox 3.0.8 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 36045 ()

Bugtraq ID: 34181
34235

CVE ID: CVE-2009-1044
CVE-2009-1169

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now