FreeBSD : cups -- potential buffer overflow in PNG reading code (87106b67-be13-11dd-a578-0030843d3802)

This script is Copyright (C) 2008-2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

CUPS reports :

The PNG image reading code did not validate the image size properly,
leading to a potential buffer overflow (STR #2974)

See also :

http://www.cups.org/str.php?L2974
http://svn.easysw.com/public/cups/trunk/CHANGES-1.3.txt
http://www.openwall.com/lists/oss-security/2008/11/25/2
http://www.nessus.org/u?1fa6baad

Solution :

Update the affected package.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 34980 (freebsd_pkg_87106b67be1311dda5780030843d3802.nasl)

Bugtraq ID:

CVE ID: CVE-2008-5286

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now