CUPS < 1.3.7 Multiple Vulnerabilities

This script is Copyright (C) 2008-2016 Tenable Network Security, Inc.

Synopsis :

The remote printer service is affected by multiple vulnerabilities.

Description :

According to its banner, the version of CUPS installed on the remote
host is affected by several issues :

- A buffer overflow exists in 'cgiCompileSearch' that
could lead to arbitrary code execution (STR #2729).

- A GIF image filter overflow exists involving 'code_size'
value from a user-supplied GIF image used in
'gif_read_lzw' (STR #2765).

- A temporary file with Samba credentials may be left
behind by cupsaddsmb if no Windows drivers were
installed (STR #2779).

See also :

Solution :

Upgrade to CUPS version 1.3.7 or later.

Risk factor :

Low / CVSS Base Score : 2.6
CVSS Temporal Score : 2.3
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 31730 (cups_1_3_7.nasl)

Bugtraq ID: 28307

CVE ID: CVE-2008-0047

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now